Subject: [Gimp-gui] Icon Theme - different measure between Legacy and Color

From: Americo Gobbo <[email-masked]>
Date: Sat, 5 Mar 2016 15:40:01 -0300

Hi
I have noted that the Legacy and Color icon themes have different measures
between them.
Color is more great than Legacy, this is normal.
I have installed the last git devel master - commit 019547c

Thanks,
americo
_______________________________________________
gimp-gui-list mailing list
[email-masked]
https://mail.gnome.org/mailman/listinfo/gimp-gui-list

---

From: Jehan <[email-masked]>
Date: Sat, 05 Mar 2016 19:48:26 +0100

Hi,

On 2016-03-05 19:40, Americo Gobbo wrote:
> Hi
> I have noted that the Legacy and Color icon themes have different
> measures between them.

Do you mean different sizes? If so, that should not be for the time 
being, though we are pondering changing some sizes (like 22px tool icons 
which is a strange in-between of commoner 20px or 24px). But right now, 
they are same.
Do you have specific examples of icons which would be in different 
sizes?

Or if that was not what you meant, I don't understand what "measures" 
you tell about.

> Color is more great than Legacy, this is normal.

I guess that's a matter of taste. I like the new Color icon colors too. 
But maybe they could be considered a little too vivid by some people, I 
guess. I have been wondering.
Anyway now there will be for all tastes.

Jehan

---
ZeMarmot open animation film
http://film.zemarmot.net
Patreon: https://patreon.com/zemarmot

>  https://mail.gnome.org/mailman/listinfo/gimp-gui-list [1]
> 
> Links:
> ------
> [1] https://mail.gnome.org/mailman/listinfo/gimp-gui-list
>

---

From: Americo Gobbo <[email-masked]>
Date: Sat, 5 Mar 2016 16:07:02 -0300

On Sat, Mar 5, 2016 at 3:48 PM, Jehan <[email-masked]> wrote:

> Do you mean different sizes? If so, that should not be for the time being,
> though we are pondering changing some sizes (like 22px tool icons which is
> a strange in-between of commoner 20px or 24px). But right now, they are
> same.
> Do you have specific examples of icons which would be in different sizes?
>
> Or if that was not what you meant, I don't understand what "measures" you
> tell about.
>

Sorry ;-) the sizes.

> Anyway now there will be for all tastes.

https://goo.gl/6hO165 > Color icon theme
https://goo.gl/Tp1h5P > Legacy icon theme

---

From: Kevin Payne <[email-masked]>
Date: Sat, 5 Mar 2016 19:20:46 +0000

I think it's very possible that the icon sizes are different. As I've been pointing out, you have no idea what sizes are been requested and as Jehan said, if an image file is close to the requested size, you get the image file at it's native size, so a request for a 22x22 that finds a 24x24 file will render the icon at 24x24.

It's a mess that needs someone with the right tools to create the authoritative list of required icon sizes as the current list is wrong.

Kevin

--- Original Message ---

From: "Americo Gobbo" <[email-masked]>
Sent: 5 March 2016 19:07
To: "Jehan" <[email-masked]>
Cc: "gimp-gui-list" <[email-masked]>
Subject: Re: [Gimp-gui] Icon Theme - different measure between Legacy and       Color

On Sat, Mar 5, 2016 at 3:48 PM, Jehan <[email-masked]<mailto:[email-masked]>> wrote:
On 2016-03-05 19:40, Americo Gobbo wrote:
Hi
I have noted that the Legacy and Color icon themes have different
measures between them.

Do you mean different sizes? If so, that should not be for the time being, though we are pondering changing some sizes (like 22px tool icons which is a strange in-between of commoner 20px or 24px). But right now, they are same.
Do you have specific examples of icons which would be in different sizes?

Or if that was not what you meant, I don't understand what "measures" you tell about.

Sorry ;-) the sizes.

I guess that's a matter of taste. I like the new Color icon colors too. But maybe they could be considered a little too vivid by some people, I guess. I have been wondering.
Anyway now there will be for all tastes.

---

From: "Aurore D. " <[email-masked]>
Date: Sun, 6 Mar 2016 20:14:45 +0100

In this case, it seem to be a problem with one single icon, the
gimp-tool-measure.png one.
With the "Small" theme, the icons used are the 16*16px ones, and in
the "icon/Color/16" folder, gimp-tool-measure.png is 22*22px.

Changing it to 16px (and compiling) seem to fix the problem.

There's another one of the wrong size in that folder by the way, it's
gimp-display-filter.png (24*24px)

On 5 March 2016 at 20:20, Kevin Payne <[email-masked]> wrote:
> I think it's very possible that the icon sizes are different. As I've been
> pointing out, you have no idea what sizes are been requested and as Jehan
> said, if an image file is close to the requested size, you get the image
> file at it's native size, so a request for a 22x22 that finds a 24x24 file
> will render the icon at 24x24.
>
> It's a mess that needs someone with the right tools to create the
> authoritative list of required icon sizes as the current list is wrong.
>
> Kevin
>
> --- Original Message ---
>
>> though we are pondering changing some sizes (like 22px tool icons which is a
>> strange in-between of commoner 20px or 24px). But right now, they are same.

-- 
Aurore